[ntp:questions] New to NTP on Linux

dusty bin junkmail at mmscomms.demon.co.uk
Tue Oct 26 11:02:40 UTC 2004

Brad Knowles <brad at stop.mail-abuse.org> wrote in message news:<mailman.48.1098714862.72027.questions at lists.ntp.isc.org>...
> At 5:53 AM -0700 2004-10-25, dusty bin wrote:
> >  Presently running NTP on three W2K machines from 486 up to PII.
> >  I want to add some refclocks using a) Garmin GPS25LVS and/or b)
> >  Jonathan's MSF Rx.
> 	Cool!
> >  Correct me if I am wrong, but this seems to imply running at least one
> >  machine on Linux (of which my knowledge is minimal)...
> 	You can, but it's not strictly necessary.  I believe that the 
> Windows port of the reference implementation will also support 
> refclocks.  Of course, Windows has other problems with its clock, so 
> you may very well be better off running another OS.

I did attempt ref clock type 20 on W2K but it didn't work - I didn't
try very hard because the Windows info on ref clocks suggests only a
couple have been implemented.  The Garmin was on serial port 1 and I
think I tried both and without success.
> 	If you're using an Intel box and looking for an alternative OS to 
> run other than Windows, but which provides good support for NTP, my 
> personal view is that FreeBSD is a better choice.  But that's only my 
> personal view.

Thanks for the info on FreeBSD - I'll persevere with Gentoo for a bit
and see how things turn out.

> >  After a fair bit of faffing about, I now have Gentoo booting to the
> >  commandline - so what next (I can't believe it would be as simple as
> >  just doing #emerge ntp, etc.)?
> 	That would be a question you should probably ask on the mailing 
> lists and newsgroups that are specific to your OS.

I ran emerge last night and it installed v4.1.2 - I should probably
have updated Gentoo portage before.  Next task is to find out how to
upgrade to v4.2.0...

> 	I don't think the Garmin is going to do very well in this job. 
Yes, agreed.  It doesn't do position hold, but I am still hoping it
will get me to around a microsecond - we'll see.
> Specifically, you would want the Motorola Oncore M12+T.
I'd give it a shot if I could find a cheap Oncore or Jupiter board.

> Jonathan's MSF stuff may be a better option than the Garmin.

I got a couple of cheap clocks from Maplin - the clocks work, but
don't set the time from MSF.  They have what looks like the EM2 board
inside which is producing pulses... so it it the controller that is
duff or the EM2, I don't know yet - so I'm holding back on this for
the time being.
> Either way, I think you will definitely need the PPSKit mods.

OK, that's what I thought.  My kernel is 2.4.25 (I think) - does that
mean I need to downgrade to 2.4.21 to install the patch?
The NMEA ref clock description refers to using ppsapi if available, so
I take it that I would not need to use the pps ref clock as well.
Also trying to interpret the ref clock, if I use (u=1),
does that mean I need to make some link from /dev/gps1 -> /dev/ttyS0
if I am using the COM1 port?  I'm not sure if that is what it is
trying to say...

Thanks for all the detailed suggestions - they have certainly help to
clear up a few issues in my mind.

More information about the questions mailing list