[ntp:questions] Problem with NTP not keeping clock in sync under Ubuntu linux

Laurence Rowe l at lrowe.co.uk
Wed Aug 10 12:48:31 UTC 2005

Hi there,

I am having problems getting NTP to take effect. My computer has a very 
fast clock (about 10 mins per day) and NTP seems to have no effect, 
though superficially appears to be work. Any ideas how to make ntp keep 
my clock in sync?

Thanks in advance,


$ ntpq
ntpq> pe
      remote           refid      st t when poll reach   delay   offset 
  maverick.mcc.ac     2 u   59   64  377    0.531  -574865 
  veracity.mcc.ac     2 u   42   64  377    0.773  -575023 
  utserv.mcc.ac.u   2 u   64   64  377    0.582  -575328 
  scarp.mc.man.ac   2 u    2   64  377    0.534  -575315 
ntpq> version
ntpq 4.2.0a at 1:4.2.0a-11-r Mon Mar 14 12:39:33 GMT 2005 (1)

$ cat /var/lib/ntp/ntp.drift

I have tried removing ntp.drift and restarting ntp-server, but ntp.drift 
is always written out as 0.000

$ cat /etc/ntp.conf
# /etc/ntp.conf, configuration for ntpd

# don't worry about the clock being out of step a long way
tinker panic 0 stepout 0

# ntpd will use syslog() if logfile is not defined
logfile /var/log/ntpd

driftfile /var/lib/ntp/ntp.drift
statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

server ntp2a.mcc.ac.uk
server ntp2b.mcc.ac.uk
server ntp2c.mcc.ac.uk
server ntp2d.mcc.ac.uk
#server ntp.ubuntulinux.org

# pool.ntp.org maps to more than 100 low-stratum NTP servers.
# Your server will pick a different set every time it starts up.
#  *** Please consider joining the pool! ***
#  ***  <http://www.pool.ntp.org/#join>  ***
#server pool.ntp.org

# ... and use the local system clock as a reference if all else fails
# NOTE: in a local network, set the local stratum of *one* stable server
# to 10; otherwise your clocks will drift apart if you lose connectivity.
#fudge stratum 13

# By default, exchange time with everybody, but don't allow configuration.
# See /usr/share/doc/ntp-doc/html/accopt.html for details.
restrict default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict nomodify

# I have also tried adding the following but to no effect
restrict ntp2a.mcc.ac.uk
restrict ntp2b.mcc.ac.uk
restrict ntp2c.mcc.ac.uk
restrict ntp2d.mcc.ac.uk

/var/log $ cat ntpd
10 Aug 07:40:04 ntpd[2194]: frequency initialized 0.000 PPM from 

More information about the questions mailing list