[ntp:questions] Re: Re: NTPD on Windows NT4

David J Taylor david-taylor at blueyonder.co.not-this-bit.nor-this-part.uk.invalid
Mon Aug 15 06:57:09 UTC 2005

Folks, I had the two messages below directly via e-mail but not via the 
newsgroup.  I'll reply to them here.  Here's the second.


[From: Heiko]

>> - using either the ntp-4.2.0a at 1.1354-o-win32-setup.exe or 
>> ntp-4.2.0a at 1.1370-o-win32-setup.exe from Meinberg, the setup failed at 
>> the point where it tried to install the service, however...
This seems to be a bug in the installer, but I was able to install the
service here under NT4. Did you try to install it using the SYSTEM
account (in order to be sure that this is no access restrictions related)?

== I tried both with the SYSTEM account and a special ntp account which I 
allowed the installer to create.

>> - I think both Meinberg versions contain the same .exe files - the 1370 
>> .exe files appear to be dated.
> I've no clue. Heiko would know.
No, they should contain different exe versions, but I'll check that when
I get back to my desk on Monday.

== Thanks, it may be that both are April 2005, and I was expecting one to 
be more recent.

> That one may well have the changes I made to the I/O completion ports 
> code. It depends on when it got built. It may well affect your charts. 
> I'd be interested in seeing the charts.
No, that version contains a workaround for bug #450, it overrides the
interface detection routines and simply binds to the first interface it
sees. This version is only usable on systems with only one interface
(i.e. one network interface card and one TCP/IP interface). I created it
for a few customers who experienced the same problems (no remote 

Kind regards,

Thanks, Heiko.  I hope you and Danny can sort this one out, as there are 
still many NT4 systems working happily away out there.  The NT4 system I 
have has no plans to be upgraded.



More information about the questions mailing list