[ntp:questions] Re: PPS source not always being chosen?

John Ackermann N8UR jra at febo.com
Tue Aug 16 12:13:24 UTC 2005

Hal Murray wrote:

> I went browsing in the Linux kernel and couldn't find any code
> to disable the FIFO.  I'm running a 2.4.16-NANO that's
> a couple of years old.  Did I miss it and/or is it in newer
> kernels?
> I was expecting an ioctl but didn't find any code that turned
> off the FIFOs.
> I think I could easily hack the kernel.  At least for serial ports
> using/emulating 16550A class chips which is what I've got.

You can do something close to disabling the fifo using the setserial 
option "low_latency".  I have a page with info and comparison of 
timestamp performance using various serial options on both Linux and 
FreeBSD at


More information about the questions mailing list