[ntp:questions] Re: ACTS - too many recvbufs allocated (40) (Correct the Version of ntp-dev)

David L. Mills mills at udel.edu
Fri Feb 18 23:06:00 UTC 2005


Ronan,

Some kernels require CLOCAL to be set for remote connections in order to 
enable modem control interrupts and some do not. On the Ultra10s here 
the DSR bit is dark, so the modem has not asserted Data Set Ready. It 
should come up only after the call is answered. Your modems, internal 
and external, should operate the same way. Start with the trace turned 
on and look for the line with "modem status". The hex number displayed 
is the status bits defined in the termios.h header file. If the 
TIOCM_DSR (400) bit is lit, your modem does not conform to the Bell 103 
specification. It might well be that some Hayes command can turn it off.

If DSR is lit at startup, the port is presumed connected to a PPS source 
and interrupts are enabled. I suspect your internal modem does provide a 
DSR signal at startup, which would be an error. However, in either case, 
there should be no I/O error and the modem should continue normally. I 
can't reproduce your problems here.

At least for the ACTS and USNO services, the driver must run in raw mode 
in order to capture an accurate timestamp for the on-time character.

Dave

Ronan Flood wrote:
> On Wed, 16 Feb 2005 17:32:04 +0100, cipo <cseplo_l at netlock.net> wrote:
> 
> 
>>When using internal PCI hsf modem, after the first successfully received 
>>packet the acts: ioctl: input/output error occured, no successfull 
>>connect anymore. This is resolved by removing
>>                if (ltemp & TIOCM_DSR)
>>                        ttyp->c_cflag &= ~CLOCAL;
>>lines in ntp_refclock.c/refclock_setup().
>>Are these lines necessary?
> 
> 
> That's the question I asked a while ago, and I still think it's
> a pertinent one.  If not using PPS, as you are not, is there any
> reason for turning off CLOCAL?  Do any of the refclock drivers
> need to know that carrier has dropped?
> 
> Even if PPS is in use, only turn off CLOCAL if necessary, and then
> watch out for hangups.  That's the problem reported here for the
> SunFire V210 onboard serial port, sudriver: unless and until Sun
> produces a new patch, it requires CLOCAL off for PPSAPI PPS to work,
> and soft-carrier on to prevent hangups being seen.
> 
> 
>>Without them my external modem works fine 
>>too. Maybe this is the internal modem driver's fault.
> 
> 
> Possibly the internal modem asserts DSR, whereas the external
> modem does not.
> 



More information about the questions mailing list