[ntp:questions] NTPD Sync. Problem

Garrett garrett.hennessey at gmail.com
Tue Dec 19 00:51:51 UTC 2006

Hello -

I have a ntpd process running, but it never seems to update its local
time to the primary time server. When I run "ntpq -pn" I get:

bash-2.05# ntpq -pn
     remote           refid      st t when poll reach   delay   offset
==============================================================================     .LOCL.          16 l    2   64  377    0.000    0.000
 0.001   .LOCL.         1  u    5   64    0    0.000    0.000

The system has been running for days like this, and neither server is
ever prefixed with an "*" indicating the server time is being used.

I am running this on a linux system which I want to serve time to other
computers on my local network when the primary time server is
unavailable. The linux system also should sync its time to  the primary
time server when that computer is available (it won't be always), and
when it's not available it should serve it's local time to the other
clients on the network.

Primary Time Server:
The linux server IP:

Here's my ntp.conf for the linux server:
fudge stratum 16
driftfile /var/lib/ntp/drift
restrict mask nomodify notrap

The other clients on the network are able to get time from the linux
server, but it's serves the local time which is different from the time
at It never updates it's local time to that of (primary time server).

When I run "w32tm /monitor /computers:" from a windows pc
on the network I get: []:
    ICMP: 0ms delay.
    NTP: -371.0058478s offset from local clock
        RefID: 'LOCL' []

This at least indicates the linux server responds to ntp requests.

What am I missing here? ANy help would be greatly appreciated!



More information about the questions mailing list