[ntp:questions] slowly gaining time

Steve Kostecke kostecke at ntp.isc.org
Sat Dec 23 15:47:57 UTC 2006


On 2006-12-23, Jammer <ask.me at mail.com> wrote:

> Steve Kostecke wrote:
>
>> Please tell us what hardware, OS, ntpd and kernel version you're
>> using.
>
> I have a Linux-2.6.19.1 kernel so nuff said. :-)

If you google for 2.6.19+ntpd you'll find some problem reports.

It is possible that your kernel timer interrupt runs at something
other than 100 Hz. This can cause problems for ntpd. You will need to
recompile your kernel to change this setting. The default MZ setting is
in /kernel/Kconfig.hz in the 2.6.19 source tree.

>> Is this machine using ACPI or APM?
>
> kernel: ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])

Changes to your CPU frequency can greatly affect ntpd.

Does passing NOACPI as a (boot time) kernel argument help?

-- 
Steve Kostecke <kostecke at ntp.isc.org>
NTP Public Services Project - http://ntp.isc.org/




More information about the questions mailing list