[ntp:questions] ntpq times out if NMEA refclock configured?

R Jenkins not at pub.lished
Sat May 13 20:48:18 UTC 2006


I'm trying to add a GPS refclock to my server.
After total failure with a basic Trimble TSIP output GPS plus the parse 
clock, I'm now using a Garmin GPS25 and the NMEA refclock.

I'm getting a very strange effect:

If the NMEA refclock is enabled in my ntp.conf, ntpq stops working, it just 
times out.
ntptime still works any gives a something like reasonable display.

I have three other servers listed in ntp.conf & simply commenting out the 
NMEA refclock lines allows ntpq to work again.

I've tried commenting out all the restrict lines, this does not change the 

This is what I'm adding in ntp.conf - I've also tried it with & without the PPS driver & 'enable pps' command.

# NMEA Clock using Garmin GPS
server prefer
fudge refid GPS flag3 1 time1 0.042

ntptime produces this:

ntp_gettime() returns code 0 (OK)
  time c810bfbb.0cb40000  Sat, May 13 2006 21:27:39.049, (.049622),
  maximum error 192016 us, estimated error 16 us
ntp_adjtime() returns code 0 (OK)
  modes 0x0 (),
  offset 0.000 us, frequency -495.911 ppm, interval 4 s,
  maximum error 192016 us, estimated error 16 us,
  status 0x1 (PLL),
  time constant 0, precision 1.000 us, tolerance 496 ppm,
  pps frequency -495.911 ppm, stability 0.000 ppm, jitter 0.000 us,
  intervals 0, jitter exceeded 0, stability exceeded 0, errors 0.

but ntpq does this after about 10 seconds:
 ntpq -c peers
localhost.localdomain: timed out, nothing received
***Request timed out

I've previously added the ppskit-lite patch to the kernel, which is 
on Centos 4.3 x86-64, Athlon 64 CPU.
I have udev configured to link /dev/gps0 to /dev/ttyS0 which I believe is 
what the NMEA refclock expects (& also to /dev/pps0 for the pps clock).
The GPS is on ttyS0 with the PPS signal converted to +/- 12V on pin 1.

I've tried the standard Centos RPM for NTP & I'm now using one built on the 
machine from the Redhat source rpm (ntp-4.2.0.a.20040617-4.src.rpm).
This seems to be configured as standard to enable all refclocks & it appears 
to be recognising the kernel PPS capability during the configure stage.

Any ideas appreciated!

Robert Jenkins.

More information about the questions mailing list