[ntp:questions] ntpdc ***Server reports a format error in the received packet (shouldn't happen)

Mad Timekeeper junkmail at blackhole.happy-fish.org.uk
Mon Sep 18 11:47:45 UTC 2006

I have just started experimenting with FreeBSD
(system="FreeBSD/6.1-RELEASE") and compiled a kernel with PPS_SYNC.
Installed NTP version="ntpd 4.2.3p21 at 1.1440-o Thu Sep 14 22:36:07 UTC
2006 (1)"

When I use the restrict command locally it works fine, but when I use
it from my W2K machine to the FreeBSD machine, I get: 

ntpdc> restrict xxx.xxx.xxx.xxx nopeer notrap noquery
***Warning changing to older implementation
***Warning changing the request packet size from 160 to 48
***Server reports a format error in the received packet (shouldn't

I have tried a few times with some different restriction, but always
seems to fail.  The first two lines only appear for the first comand.
The unrestrict command has worked OK for the few times I have tried.

ntpdc on W2K machine reports : ntpdc 4.2.0a at 1.1391-o Dec 07 15:59:06
(UTC+01:00) 2005  (1).

As an aside, ntpdc -c monlist times out when requested locally, but
responds OK when the request comes from the W2K machine.

More information about the questions mailing list