[ntp:questions] Local clock question with dialup connection

Nigel Henry cave.dnb at tiscali.fr
Thu Apr 19 18:07:49 UTC 2007

On Thursday 19 April 2007 19:11, Danny Mayer wrote:
> Nigel Henry wrote:
> > On Thursday 19 April 2007 05:12, Danny Mayer wrote:
> >> Harlan Stenn wrote:
> >>>>>> In article <200704162309.24517.cave.dnb at tiscali.fr>,
> >>>>>> cave.dnb at tiscali.fr (Nigel Henry) writes:
> >>>
> >>> Nigel> djmons at localhost djmons]$ /usr/sbin/ntpq
> >>> ntpq> pe
> >>> Nigel> localhost.localdomain: timed out, nothing received ***Request
> >>> timed Nigel> out
> >>>
> >>> This looks like ntpd is not running at the time you did this.
> >>
> >> No, you would not get Request timed out, you would get connection
> >> refused. It may be that the server is just dropping your queries.
> >>
> >> Danny
> >
> > FC5 isn't giving me this problem using 4.2.4p0-1.fc6. I do have the 2
> > local clock lines (server, and fudge) uncommented, and when I boot the
> > machine with no Internet connection, then after connecting to the
> > Internet (dialup) , I run ntpq> pe, it shows local as a system peer, and
> > 3 servers from fedora.pool.ntp.org dynamic. It does take ages before one
> > of the servers is set as system peer, but it's working.
> >
> > On FC2 using 4.2.0-7, I am using 3 specific stratum2 servers, rather than
> > a pool. Could it be that because I only have 3 specific servers, that
> > they are being tried once while there is no initial Internet connection
> > on bootup, are failing to be found, and ntpd is not trying them again.  I
> > presume a server pool has many available servers, so if I have a server
> > pool in /etc/ntp.conf, does ntpd just keep on trying to get a response in
> > this case, like it tries the pool, doesn't get a response, tries again,
> > no response, tries again, and so on, by which time I have made the
> > Internet connection, and it's still trying to find a pool server, and now
> > with an active Internet connection it gets a response, and sets up 3
> > available Internet servers?
> >
> > As I'm having problems installing 4.2.4p0 from the tarball on FC2, I
> > think I'll try reinstalling 4.2.0-7, put a server pool in /etc/ntp.conf,
> > and see just for hell of it, if it works.
> >
> > All in a days work.
> >
> > Nigel.
> That's not the issue. The question really is what you have in your
> ntp.conf file. If you have restrict statements in the file ntpd may just
> drop queries like you are making and therefore ntpq will just time out.
> It's hard to know without seeing the config file.
> If it takes a long time to get a preferred server, you are probably not
> using the iburst option on the server lines. It speeds up
> synchronization considerably.
> Danny

I havn't used iburst before, but bear in mind that when I boot up there is no 
Internet connection. As I mentioned above, I've reinstalled 4.2.0-7, and used 
the servers from FC6's /etc/ntp.conf file for 4.2.4p0. /etc/ntp.conf is very 
basic, and I removed "dynamic" from the end of the server lines, as otherwise 
there were problems using the file with 4.2.0-7 on FC2. See below.

# Use public servers from the pool.ntp.org project.
# Please consider joining the pool (http://www.pool.ntp.org/join.html).
server 0.fedora.pool.ntp.org
server 1.fedora.pool.ntp.org
server 2.fedora.pool.ntp.org

# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. 
#server # local clock
#fudge stratum 10

# Drift file.  Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
driftfile /var/lib/ntp/drift

It's getting better, and booting up with no Internet connection, then 
connecting to the Internet, then running ntpq< pe gives me just one available 
server, and that is one using an IP address rather than a hostname, so there 
appears to perhaps be a slight DNS problem.

 ntpq> pe
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================   .INIT.          16 u    -   64    0    0.000    0.000 4000.00
ntpq> pe
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================    2 u   31   64    1  148.565  -1745.9   0.001
ntpq> pe
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================    2 u   40   64    3  148.565  -1745.9  21.924
ntpq> pe
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================    2 u   49  128    7  148.565  -1745.9  15.573
ntpq> pe
     remote           refid      st t when poll reach   delay   offset  jitter
*    2 u  319  512   37  148.565  -1745.9  15.685

Stopping and then starting ntpd, and running ntpq> pe now gives me the 
expected 3 Internet servers from the pool.

ntpq> pe
     remote           refid      st t when poll reach   delay   offset  jitter
 dedibox.ebzao.i   2 u   26   64    1  140.115  -14.301   0.001
 chime6.surfnet. .PPS.            1 u   25   64    1  139.069  -16.197   0.001
 i216-58-31-84.c    3 u   23   64    1  258.237    0.795   0.001

It looks like I need to delay ntpd being started at bootup, or at least delay 
the polling of the servers. I see there is a script for this in the 4.2.4p0 
version, but can't see such a workaround on a rpm installed version as the 
4.2.0-7 version is on FC2.

I think ideally what I need is a script that will detect when the Internet 
connection is up, and then start ntpd. I can't see there being any problems 
then.  If you can suggest a suitable script that would be great, otherwise 
I'll ask on some other lists. I've little experience on writing scripts.

Someway or other this is going to be fixed.


More information about the questions mailing list