[ntp:questions] Local clock question with dialup connection

Nigel Henry cave.dnb at tiscali.fr
Fri Apr 20 21:10:06 UTC 2007

On Thursday 19 April 2007 19:11, Danny Mayer wrote:
> Nigel Henry wrote:
> > On Thursday 19 April 2007 05:12, Danny Mayer wrote:
> >> Harlan Stenn wrote:
> >>>>>> In article <200704162309.24517.cave.dnb at tiscali.fr>,
> >>>>>> cave.dnb at tiscali.fr (Nigel Henry) writes:
> >>>
> >>> Nigel> djmons at localhost djmons]$ /usr/sbin/ntpq
> >>> ntpq> pe
> >>> Nigel> localhost.localdomain: timed out, nothing received ***Request
> >>> timed Nigel> out
> >>>
> >>> This looks like ntpd is not running at the time you did this.
> >>
> >> No, you would not get Request timed out, you would get connection
> >> refused. It may be that the server is just dropping your queries.
> >>
> >> Danny
> >
> > FC5 isn't giving me this problem using 4.2.4p0-1.fc6. I do have the 2
> > local clock lines (server, and fudge) uncommented, and when I boot the
> > machine with no Internet connection, then after connecting to the
> > Internet (dialup) , I run ntpq> pe, it shows local as a system peer, and
> > 3 servers from fedora.pool.ntp.org dynamic. It does take ages before one
> > of the servers is set as system peer, but it's working.
> >
> > On FC2 using 4.2.0-7, I am using 3 specific stratum2 servers, rather than
> > a pool. Could it be that because I only have 3 specific servers, that
> > they are being tried once while there is no initial Internet connection
> > on bootup, are failing to be found, and ntpd is not trying them again.  I
> > presume a server pool has many available servers, so if I have a server
> > pool in /etc/ntp.conf, does ntpd just keep on trying to get a response in
> > this case, like it tries the pool, doesn't get a response, tries again,
> > no response, tries again, and so on, by which time I have made the
> > Internet connection, and it's still trying to find a pool server, and now
> > with an active Internet connection it gets a response, and sets up 3
> > available Internet servers?
> >
> > As I'm having problems installing 4.2.4p0 from the tarball on FC2, I
> > think I'll try reinstalling 4.2.0-7, put a server pool in /etc/ntp.conf,
> > and see just for hell of it, if it works.
> >
> > All in a days work.
> >
> > Nigel.
> That's not the issue. The question really is what you have in your
> ntp.conf file. If you have restrict statements in the file ntpd may just
> drop queries like you are making and therefore ntpq will just time out.
> It's hard to know without seeing the config file.
> If it takes a long time to get a preferred server, you are probably not
> using the iburst option on the server lines. It speeds up
> synchronization considerably.
> Danny

I've been seriously reading the docs today, and have found a server option 
for /etc/ntp.conf named "calldelay", which says it works with burst, or 
iburst. iburst sends a pkt, then calldelay delays the sending of the second 
packet by howmany seconds you have set to delay the sending of the second pkt 
by. This seems like what I'm looking for, but am not sure how to setup 
calldelay in /etc/ntp.conf.

I tried adding iburst calldelay 600 to the end of each of the server lines, 
but zilch. I boot up, then connect to the Internet, run ntpq> pe, but get "No 
association ID's returned". I did continually try ntpq> pe, as the delay 
maybe hadn't expired.

If calldelay is still a valid server option, how do I set it up 
in /etc/ntp.conf?

I'm fast coming to the conclusion, that at least on this FC2 install, it might 
be best to do a chkconfig ntpd off, then just boot FC2, and start ntpd from 
the command line after I've made the Internet connection.

Anyway when ntpd is running properly, the time is ok, so I'm not complaining.


More information about the questions mailing list