[ntp:questions] Unable to use SUSE Linux for time synchronization.

sandy sandypossible at gmail.com
Fri Feb 9 17:49:36 UTC 2007

I am trying to use Linux NTP server for time sync with my target in
unicast mode. This target has the sntp client version 4 as per RFC
2030. I tried to time sync using windows domain controller. With
windows DC as time server, it works fine.

I have problem when using SUSE Linux as time server. When I try to use
linux as time server, Linux replies with LI leap indicator flags set
to "alarm condition (clock not synchronized)". As per RFC 2030, as
unicast mode is used, as LI is 3, the reply is getting rejected. My
Linux time server is standalone system. It is not getting time synched
with external source. Could this the be the reason ?

I tried to use the Linux time server as client. But even in this case
too, Linux request has the
Leap indicator value set to 3.

Can you please tell me what could be wrong  ? What exactly is meant by
""alarm condition (clock not synchronized)" ?  How to make use of
Linux NTP server correctly ?

Is it related to configuration issue ? Do I need to use a particular
stratum ?


More information about the questions mailing list