[ntp:questions] Meinberg DCF77 C51 with Linux 2.6

Maurice Janssen mauricej at xs4all.nl
Sat Feb 10 18:29:15 UTC 2007

On Sat, 10 Feb 2007 18:55:45 +0100, Rune Magnussen wrote:
>I am trying to to get my Meinberg DCF77 C51 unit to work. The problem is
>that ntpd does not see any timecodes even though thr unit is synchronised
>to the radiosignal.
>The clock is connected via a modem cable with a null-modem
>adapter. I tried with a serial printer cable as well, but not for long. The
>serial port is detected by the kernel. As described in the docs I made a 
>symlink /dev/refclock-0 to /dev/ttyS0. I guess that /dev/ttyS0 is the right one.
>as the PC only has one serial port on the outside.
>The DCF77 C51 shows up as GENERIC(0) with refid DCFa but the clock is never
>"reached". I have activated clockstats in ntpd, but nothing shows up.
>What should I try next?

Have you tried without the null-modem cable?  IIRC you need a straight
cable (like you would use between computer and external modem).


More information about the questions mailing list