[ntp:questions] HopfClockSerial with Suse 10.2

Gerhard Pisl gerhard at pisl.de
Tue Feb 20 20:10:53 UTC 2007

Hello Martin,
Thanks for your reply it was exactly what you suspected.

Perhaps one remark for the community:
I got the HopfClock Serial 6020, which actually doesn't work with the
HopfClockSerial Driver (, but with the Generic DCF77 Driver
( because this clock can not be switched to GMT-format.
Reason being: The hopf driver covers all clocks starting with 6021 upwards.
Strange but that's life.


-----Ursprüngliche Nachricht-----
Von: questions-bounces+gerhard=pisl.de at lists.ntp.isc.org
[mailto:questions-bounces+gerhard=pisl.de at lists.ntp.isc.org]Im Auftrag
von Martin Burnicki
Gesendet: Dienstag, 20. Februar 2007 09:51
An: questions at lists.ntp.isc.org
Betreff: Re: [ntp:questions] HopfClockSerial with Suse 10.2


I'll help you though I'm working for Meinberg, not for Hopf ;-)

Gerhard Pisl wrote:
> Hello,
> I currently try to get a HopfClock Serial 6020 to run with NTP under Linux
> SuSE 10.2.
> This configuration already ran under Suse 9.1 and NTP version 4.2.0a
> successfully.
> Now I updated the system to Suse 10.2. and NTP version 4.2.2p4 (from
> scratch installation).
> Result:
> 1) Everything works with time servers from the Internet
> 2) The HopfClock writes a message into the /var/log/warn file and is not
> even listed (ntpq -p):
>   Feb  8 20:45:07 earth ntpd[15469]: refclock_open /dev/hopfclock0:
> Operation not permitted

This is not a problem of ntpd, but a problem of AppArmor which comes with
SUSE Linux and is enabled by default in SUSE 10.2.

For a first test you can stop AppArmor and see whether ntpd then works

If AppArmor shall be used it must be configured to allow access to the
refclock for ntpd:

Yast2 -> Novell AppArmor -> Edit Profile
Select profile /usr/sbin/ntpd
Add entry: /dev/???
# where ??? must be the device /dev/hopfclock0 points to
Mark allow for: Read, Write, Link

This generates a new entry:
/dev/???   rwl

Please note the symbolic links (e.g. /dev/hopfclock0) are also created new
after every reboot. If this doesn't appear to happen you must create an
udev rule for this.

Martin Burnicki

Meinberg Funkuhren
Bad Pyrmont

questions mailing list
questions at lists.ntp.isc.org

More information about the questions mailing list