[ntp:questions] ntpdate works only with -d option

Martin Burnicki martin.burnicki at meinberg.de
Fri Feb 23 10:16:53 UTC 2007


William Sheffler wrote:
> I'm having trouble getting ntp set up on my network. If I run
>     ntpdate -d 0.north-america.pool.ntp.org
> I get lots of very proper looking output like this:
> Unfortunately, if I run the same as above without -d (trying to actually
> set my system time):
>     ntpdate 0.north-america.pool.ntp.org
> I get an error:
>     22 Feb 02:50:46 ntpdate[7808]: no server suitable for synchronization
> found
> I'd really like to get ntp working on my machines but I'm at a total loss
> to explain this! Can anyone help?

If you run ntpdate with -d or -q then it sends it request to the server from
an unpriviledged port. 

If none of those parameters are used it sends its request from the standard
NTP port 123, which is a priviledged port (this also prevents using ntpdate
if ntpd is already running since then port 123 is has already been opened
by ntpd).

Sounds like a firewall and/or router/NAT problem which doesn't allow
outgoing and/or incoming UDP packets on port 123.

Martin Burnicki

Meinberg Funkuhren
Bad Pyrmont

More information about the questions mailing list