[ntp:questions] NTP in Multicast with a Coldfire5271 + µClinux

pierre.savary at reseau.eseo.fr pierre.savary at reseau.eseo.fr
Fri May 4 10:00:45 UTC 2007


like I say in the target of my message, I want a NTP server in Multicast
in my board Coldfire with µClinux.

The config is simple :

fudge stratum 1

broadcast ttl 255

But the multicast doesn't work with NTP. It's the only mode that doesn't
work in my NTP server.
I made a test of multicast with another service and it works so it is NTP
... but I don't know why. Maybe it's the options in my Makefile :

CONFOPTIONS=								   \
	--disable-debugging	\
	--disable-HOPFSERIAL --disable-HOPFPCI --disable-BANCOMM           \
	--disable-GPSVME --disable-SHM --disable-all-clocks                \
	--disable-ACTS --disable-ARBITER --disable-ARCRON-MSF              \
	--disable-ATOM --disable-AS2201 --disable-CHU --disable-AUDIO-CHU  \
	--disable-DATUM --disable-FG --disable-HEATH --disable-HPGPS       \
	--disable-IRIG --disable-JJY --disable-LEITCH                      \
	--disable-MSFEES --disable-MX4200            \
	--disable-NMEA --disable-ONCORE --disable-PALISADE --disable-PST   \
	--disable-JUPITER --disable-PTBACTS --disable-TPRO --disable-TRAK  \
	--disable-CHRONOLOG --disable-DUMBCLOCK --disable-PCF              \
	--disable-SPECTRACOM --disable-TRUETIME --disable-ULINK            \
	--disable-WWV --disable-USNO --disable-parse-clocks                \
	--disable-COMPUTIME --disable-DCF7000 --disable-HOPF6021           \
	--disable-MEINBERG --disable-RAWDCF --disable-RCC8000              \
	--disable-SCHMID --disable-TRIMTAIP --disable-TRIMTSIP             \
	--disable-WHARTON --disable-VARITEXT --disable-kmem                \
	--enable-LOCAL-CLOCK						   \
	--without-openssl-libdir --without-openssl-incdir --without-crypto \
	--without-electricfence --without-sntp --$(NTPDATE)-ntpdate \
	--$(NTPDC)-ntpdc --$(NTPQ)-ntpq

all: builddir
	$(MAKE) -C builddir CFLAGS='$(CFLAGS)

	$(ROMFSINST) -e CONFIG_USER_NTPD_NTPD builddir/ntpd/ntpd /bin/ntpd
	$(ROMFSINST) -e CONFIG_USER_NTPD_NTPDATE builddir/ntpdate/ntpdate
	$(ROMFSINST) -e CONFIG_USER_NTPD_NTPDC builddir/ntpdc/ntpdc /bin/ntpdc
	$(ROMFSINST) -e CONFIG_USER_NTPD_NTPQ builddir/ntpq/ntpq /bin/ntpq

builddir: makefile
	rm -rf builddir
	mkdir builddir
	( \
		cd builddir; \
		MISSING="true" \
			../configure --prefix= --host=m68k-elf \
			--with-headers=$(ROOTDIR)/$(LINUXDIR)/include \

So I don't know how make !!!! Could you give me some help please ...?


PS: sorry for my english

More information about the questions mailing list