[ntp:questions] NTP not syncing

Richard B. Gilbert rgilbert88 at comcast.net
Sat May 5 17:21:02 UTC 2007

Michael wrote:
> Hi,
> I have a GPS based NTP server on my network. It is synchronized perfectly 
> with the GPS receiver.
> I have many Gentoo based Linux servers on the same network. They are all 
> working fine
> However, they do not want to seem to sync to the server at all.
> They send UDP request out to the server and get UDP replies back as seen by 
> tcpdump.
> They dont dont want to sync up at all.
> I am running ntp 4.2.4
> My server statement is server ntpserver01 iburst burst maxpoll 7
> Anybody got any clues as to why they dont sync or how to fix it or even 
> debug why NTP
> does not seem to like the server.
> Thanks
> Michael

Start by removing the "burst" and "maxpoll 7" from your server statements!

Ntpd is designed to adjust its poll interval between the default values 
of MINPOLL and MAXPOLL as needed.   Changing these defaults is almost 
never the right thing to do.

If you are really smart enough to tinker with the design of ntpd, you 
probably don't need any help we can give!

The burst keyword is a special purpose hack designed, I believe, for 
dialup connections made at very long intervals (many hours).  It was not 
intended for general use and its use is considered abusive unless you 
own the server or have the owner's permission!  In this case you 
apparently own the server but there is no benefit to to be had from 
using burst.

Start ntpd with the "-g" option.  This will cause ntpd to set the clock, 
  on a one time basis, to a reasonable approximation of the correct time.
Wait at least thirty minutes and issue:

ntpq -p

If things don't appear to be working, post the output.

More information about the questions mailing list