[ntp:questions] 1PPS signal on Solaris 10

Thomas Tornblom thomas at Hax.SE
Wed May 9 17:57:41 UTC 2007

Dave <dave.deconsulting at gmail.com> writes:

> I have been having enormous amounts of trouble detecting a 1PPS signal
> on a 4200 (Intel x86) running Solaris 10. There is no direct serial
> port connection, so I am looking for a PCI board or some other
> alternative way of receiving this signal. I tried a serial-to-USB
> connection, but the USB port does not support the DCD pin (which PPS
> comes over on). I've also tried a Performance Technologies board, but
> the ioctl calls TIOCSPPS, TIOCGPPS, and TIOCGPPSEV all return invalid
> values. I also have a Symmetricom BC635 board which would support the
> 1PPS signal if they were to have a driver for Solaris 10, but none is
> available. I also looked into companies like Brandywine, but they
> don't support Solaris at all. Any suggestions?

I suggest trying a dirt cheap, non-intelligent, PCI serial board.

I have looked at the Perfoamnce Technologies site, and it seems
everything they have is intelligent, using Motorola QUICC processors.

You would probably have much greater success with something supported
with the "asy" driver.

I have successfully used the onboard asy ports of various x86 systems
with PPS on Solaris 10.


More information about the questions mailing list