[ntp:questions] 1PPS signal on Solaris 10

Richard B. Gilbert rgilbert88 at comcast.net
Wed May 9 19:30:52 UTC 2007

Dave wrote:
> I have been having enormous amounts of trouble detecting a 1PPS signal
> on a 4200 (Intel x86) running Solaris 10. There is no direct serial
> port connection, so I am looking for a PCI board or some other
> alternative way of receiving this signal. I tried a serial-to-USB
> connection, but the USB port does not support the DCD pin (which PPS
> comes over on). I've also tried a Performance Technologies board, but
> the ioctl calls TIOCSPPS, TIOCGPPS, and TIOCGPPSEV all return invalid
> values. I also have a Symmetricom BC635 board which would support the
> 1PPS signal if they were to have a driver for Solaris 10, but none is
> available. I also looked into companies like Brandywine, but they
> don't support Solaris at all. Any suggestions?

Yes!  Get a PC with a serial port!  You can probably find a suitable 
machine at curbside if you keep your eyes open.  Anything made in the 
last six or seven years should have more than enough processing power if 
all it has to do is run ntpd.

More information about the questions mailing list