[ntp:questions] How do I change configuration of svcadm?

Dave dave.deconsulting at gmail.com
Tue May 29 15:51:19 UTC 2007

On May 29, 11:05 am, "Richard B. Gilbert" <rgilber... at comcast.net>
> Dave wrote:
> > On May 29, 10:32 am, Casper H.S. Dik <Casper.... at Sun.COM> wrote:
> >>"Richard B. Gilbert" <rgilber... at comcast.net> writes:
> >>>If you figure it out, please let me know.  I still have to start mine by
> >>>hand.  I suppose that the new startup database is an improvement but
> >>>it's one I didn't really need; what I had WORKED.
> >>You can still use the old method and create an /etc/rc?.d script as
> >>before.
> >>Casper
> >>--
> >>Expressed in this posting are my opinions.  They are in no way related
> >>to opinions held by my employer, Sun Microsystems.
> >>Statements on Sun products included here are not gospel and may
> >>be fiction rather than truth.
> > I ended up changing the /lib/svc/method/xntp script to start the new
> > ntpd binary. The only problem I'm having now is finding a copy of
> > libcrypto.so.0.9.8. Do you know where I can get one for an x86
> > machine? I currently have 0.9.7 and thats obviously not going to work
> I tried the same thing.  I renamed the original, copied it, and modified
> the copy to start the ten-twelve years newer version of ntpd.  It
> doesn't work and I don't know why.  I just start it by hand on those
> rare occasions when I need to reboot.

I also forgot to mention that I changed /var/svc/manifest/network/
ntp.xml as well. Its pretty straight forward on what path names you
need to change. Can you post the output of the /var/svc/log/network-
ntp:default.log when you try to start it with 'svcadm enable ntp'?
Also, have you checked the status with 'svcs -x ntp'? Because all of
my paths were different, I had to start ntpd with the '-c' option in
the new method script

More information about the questions mailing list