[ntp:questions] ntpd just not working

Maarten Wiltink maarten at kittensandcats.net
Sat Oct 6 22:15:54 UTC 2007

"Michael B Allen" <ioplex at gmail.com> wrote in message
news:20071006180135.ad32ccd9.ioplex at gmail.com...

> For some reason ntpd never seems to work for me. It looks like it is
> but once in a while I start getting "clock skew too great" kerberos
> errors. I can stop ntpd and do an ntpdate to sync up and I'm ok again
> for a while.
> Here's all my info:

Not all, in fact. The first thing to look at is 'ntpq -p'. Did you
review your firewall?

> 18899 ?        SLs    0:00 ntpd -u ntp:ntp -p /var/run/ntpd.pid -g
> # cat ntp.conf
> restrict default ignore
> restrict
> server
> restrict mask nomodify notrap noquery
> driftfile /var/lib/ntp/drift

I'd be very wary of the restrictions. They look okay, but you might
try going without them for a bit. Is a good server?
Where does it get its time? What reach does it have in the ntpq output?


> Could it be that the ntpd that ships with CentOS is just crappy? Where
> can I find a good ntp daemon that works?


> Or is it because the machine is a cheapo AMD 64 thing I got from
> Circuit City?


> I should also mention that I'm running VMWare Server on the host. I
> would suspect it was responsible but changing the time in VMs reverts
> to the host time so I think that's good evidence that the host is
> authoritative.

Run NTP on the host. Enable VMware's time sync option in the VMs.

> I have also have kernel params 'acpi=off clock=pmtmr' (a previous
> effort to fix this problem).

Shouldn't matter. Might as well take them out, they probably do more
harm than good.

> Another thing that may or may not be related is that occasionally, if I
> leave an SSH session inactive for a few minutes, it becomes completely
> unresponsive for 30 seconds. Then it suddenly starts working normally
> again.

It may be related. The description is not enough to diagnose the problem.

Maarten Wiltink

More information about the questions mailing list