[ntp:questions] [solved] ntpd just not working

Nigel Henry cave.dnb at tiscali.fr
Sun Oct 7 17:40:19 UTC 2007

On Sunday 07 October 2007 18:28, Michael B Allen wrote:
> On Sun, 7 Oct 2007 11:57:39 -0400
> Michael B Allen <ioplex at gmail.com> wrote:
> > On Sun, 7 Oct 2007 14:24:39 +0200
> >
> > "Maarten Wiltink" <maarten at kittensandcats.net> wrote:
> > > You, on the other hand, have Problems. With the cut down config file,
> > > at least NTP is now starting, but you're not getting any traffic even
> > > without the restrictions. Review your firewall again, this time under
> > > the assumption that you do have one.
> >
> > No firewalls. From the capture I can clearly see only a request and
> > reply. There's no attempt to communicate with the time server at all.
> It was SELinux. Somehow the distro I'm using managed to ship an ntpd
> that was not compatible with the their selinux config.
> Thanks,
> Mike

I read some years ago, that you can have so much security on your machine, 
that you can't do anything with it anymore.

For the first time, when I installed Fedora 7, I left selinux enabled in 
enforcing mode. Ntpd is running, but only getting it's time from my other 
machine on the LAN, which is getting it's time from Internet time servers, 
and ntp is working ok on Fedora 7. I did have a problem in not being able to 
ftp into the Fedora 7 machine from the other machine, but running 
setroubleshoot told how to resolve that problem.

I don't have SElinux enabled on any of the other distros I run on my 2 
machines. I'm only a home user, so perhaps not as paranoid about security as 
someone using their machines in the corporate/business environment.

Glad you've got the problem resolved.


More information about the questions mailing list