[ntp:questions] NTPD on bond0:0 **Solved**

David A. Evans Evans_David_A at cat.com
Mon Feb 25 15:46:52 UTC 2008

        Removing the -L solved the problem but here are the answers and 
what I found through my troubleshooting.

        I'm running Red Hat Enterprise Linux ES release 3 (Taroon Update 
5) on IBM X series servers.

        These servers have 2 physical NIC's to 2 switches. 

        Old Config was 3 IP's.   2 "real" IPs on Eth0 and Eth1.   Then a 
"virtual" IP on Eth0:0 or Eth1:0.  We had some home grown scripts to fail 
the 'virtual' between the two NIC's.   This configuration, and I have 
verified this several times on this version of Redhat, requires the -L 
switch to bond to all IP's.   Removing the -L and NTP only bonds to the 
'real' IP's.   This is backwards from most of the documentation that I 
have found.  But that is the way it works.

        New Config still has multiple IP's as we have done some service 
consolidation and want to keep some old IP's to avoid client and firewall 
updates but now the drivers bond the two physical NIC's into one that 
shows up as Bond0.  This has a single IP that the drivers monitor and 
switch between whichever physical card is up at the time.   Now we still 
have virtual IP's on the machine that show up as bond0:X, however,  with 
the -L NTP only bonds to the 'real'  interfaces (as the majority of the 
docs show) and removing the -L causes it to bond to all the available 

        It looks like our old config is really where the 'bug' is.  My 
confusion started as all our internal documentation states that if you 
have virtual IP's, add the -L to make it work.  So someone several years 
ago found this issue and just 'fixed' our internal docs.  Once I stopped 
looking for documentation on bond interfaces and started looking for doc's 
on the -L switch the solution presented itself.

David A. Evans
Enterprise IP/DNS Management
Network Infrastructure Tools and Services
Evans_David_A at cat.com

Danny Mayer <mayer at ntp.isc.org> 
02/22/2008 09:15 PM
Please respond to
mayer at ntp.isc.org

"David A. Evans" <Evans_David_A at cat.com>
questions at lists.ntp.org
Re: [ntp:questions] NTPD on bond0:0

Caterpillar: Confidential Green Retain Until: 03/23/2008 

David A. Evans wrote:
>         We have recently setup our first Redhat NTP server with a bonded 

> interface.   We run NTPD on these servers on a virtual IP that used to 
> show up as eth0:0.   When it was eth0:0 the -L in the 
> worked well and NTP would service clients on the virtual IP.  Now on the 

> bond0:0 the syslog does not show a listening on message for bond0:0 and 
> netstat does not show the port on the virtual IP.   So of course it does 

> not service clients on that interface.

Is there something special about bond0 or is it just another NIC? What 
are you expecting to do when you use -L?

>         We are running version 4.2.2 at 1.1532-o.  I have checked the 
> log of the newer versions and don't see any mention of a fix on the 
> versions and google'ing bond0:0 and ntpd returns very little useful 
> information.     Does anybody else have this setup on a bond0:0 

Please upgrade to 4.2.4 first. However can you check that you are 
actually binding to the interface? It should say that it's listening on 
the address you are looking for. NTPD should listen on every interface 
on port 123 so I'd be surprised if it weren't there.

If necessary, build ntpd with debug mode and then add -D 2 -l stdout to 
the command line and it should spit out more information to stdout when 
you run it directly.


> David A. Evans
> Enterprise IP/DNS Management
> Network Infrastructure Tools and Services
> Evans_David_A at cat.com
> _______________________________________________
> questions mailing list
> questions at lists.ntp.org
> https://lists.ntp.org/mailman/listinfo/questions

More information about the questions mailing list