[ntp:questions] Generating keys for ntpdc control

Bob bobsjunkmail at bellsouth.net
Fri Jul 4 19:15:48 UTC 2008

"Martin Burnicki" <martin.burnicki at meinberg.de> wrote in message 
news:gng1k5-i11.ln1 at gateway.py.meinberg.de...
> Bob,
> I've just done some quick tests, and it worked for me.
> Installed the foehr-v2 version (should be the same you are using) on W2k
> with the following config files:
> ntp.conf:
> ---<snip>--------------------------------------
> driftfile "E:\Program Files\NTP\etc\ntp.drift"
> server gateway iburst minpoll 6 maxpoll 6
> keys "E:\Program Files\NTP\etc\ntp.key"
> trustedkey 5 6
> requestkey 5
> controlkey 5
> ---<snip>--------------------------------------
> ntp.key:
> ---<snip>--------------------------------------
> 6 M key1
> 5 M key2
> ---<snip>--------------------------------------
> Then I tried at the ntpdc prompt:
> ntpdc> addserver pc-martin iburst
> Keyid: 5
> (here should be a prompt for the MD5 password, where I entered "key2")
> done!
> So the command was successful unless I mis-typed and corrected the MD5
> password. After this ntpq -p listed the new server, so everything is fine.
> Maybe you can try to use a simple MD5 key like me, and see if it works?
> BTW, running the debug version of ntpdc did pop up the debugger, with an
> "assertion failed" message. When I ignored that failed assertion the "MD5
> password: " prompt was displayed.
> Strange, I'll have a closer look at this later.
> Martin
> -- 
> Martin Burnicki
> Meinberg Funkuhren
> Bad Pyrmont
> Germany

Got it working... thanks!
After getting past the key file content, lack of password prompt, and 
ntp.conf issue, what I finally figured out is that  ntpdc will remember that 
it got a "permission denied", and no further attempts will be made without 
stopping and restarting it. 

More information about the questions mailing list