[ntp:questions] [NOT SOLVED] Default config on Ubuntu doesn't work as client

Michael B Allen miallen at ioplex.com
Tue Mar 11 16:48:09 UTC 2008

On Tue, 11 Mar 2008 07:30:20 +0000
David Woolley <david at ex.djwhome.demon.co.uk.invalid> wrote:

> I don't know how VMWare handles the TSC, but unless it handles it in a 
> away intended for real time measurement, rather than CPU usage 
> measurement the calibration may be run at a time that doesn't match 
> average conditions.  If that theory is correct, you need to disable TSC 
> as a time source.

Well I have no idea what you just said but I suppose it means that the
problem isn't really "SOLVED" after all. And I just rebooted and the
time is off again so I wonder if iburst is really sufficient for a
robust solution.

For posterity I wanted to see if installing VMWare tools made a difference
(I bet it does) but after downloading gcc and 45MB of kernel source
it wanted me to build the kernel and that's where I throw in the
towel (the Linux kernel guys really need to figure out how to make symbol
versioning more forgiving).

And of course all of this says nothing about the default ntp.conf on
Ubuntu. I suspect it does in fact work and that the problem is just
VMWare Server (the "free" one, not ESX).


More information about the questions mailing list