[ntp:questions] strange time behaviour

vhfmeyer at t-online.de vhfmeyer at t-online.de
Mon May 25 15:30:12 UTC 2009


I have an embedded application running under Linux 2.6.22 #1 PREEMPT
with 1000 ticks per second (PC architecture, AMD Geode Processor).
Since precise timing is needed, the devices are synchronized to a time
server via ntpd 4.2.2p4.

After running 48 days and 13 hours without problems, things got crazy.
The system time slowed down for a period of time, so that the system
time lagged about three minutes to the real time. Some time later (an
hour or so), ntp corrected the problem with a time jump. The device
worked well again until 48 days and 13 hours after the first occurence
of the problem the same thing happenend again. The system clock slowed
down some 23 percent for a period of 13 minutes and 32 seconds (real
time). This behavier was the same for the four devices I run, although
the time when the problem began varied some 100 seconds between the
devices and seemingly the subjektive time too. Again ntp corrected the
problem after some time. The first time the problem occurred, the
systems claimed clocksource tsc unstable and switched to clocksource
pit. Didn't seem to make a difference.

I have no idea, what the problem is. Does anybody know, what's going
on and how to cure it?

Regards, Volker Meyer

More information about the questions mailing list