[ntp:questions] ntp not updating the time

David Woolley david at ex.djwhome.demon.invalid
Tue Apr 13 22:01:43 UTC 2010

Marc Fromm wrote:
> If I restart the ntpd service the time is updated to the correct time:
> /sbin/service ntpd restart

I.E. /etc/init.d/ntpd restart
which, although a deprecated procedure, will probably run ntpdate.

> If I run the command below the time is updated to the correct time:
> ntpdate -u time-nw.nist.gov
> If I don't do any of the above my time is never updated and the server becomes hours behind.
> How or when does ntpd automatically update the time?

When the measured error is between 128ms and 1,000 seconds and has 
persisted for about 15 minutes.  If it is less, ntpd tweaks the 
effective clock frequency every second, or asks the kernel to do so 
every tick, so as to slowly (order of hours) converge the clock onto the 
correct time.  If it is greater, ntpd aborts, as its idea of the time is 

Note, selective failures of ntpd relative to some options of ntpdate can 
be due to firewalling of UDP port 123.

The standard ntpq diagnostics (peers, rv 0, assoc, rv for every 
association id) and the syslog entries would be helpful, together with 
any local changes to the configuration file.  You should leave the sytem 
running for at least 30 minutes before running ntpq (less is possible, 
but 30 minutes should cover all likely settings).

As service is part of RedHat, not ntpd, and /etc/init.d/ntpd will also 
be part of RedHat, I assume you are using some version of RedHat, but 
you really should have told us which, and which version of ntpd.

More information about the questions mailing list