[ntp:questions] help needed for ntpd ipv6 setup

E-Mail Sent to this address will be added to the BlackLists Null at BlackList.Anitech-Systems.invalid
Thu Dec 2 03:09:34 UTC 2010

Marc-Andre Alpers wrote:
> Es schrieb horhe:
>> I think this is the same "bug" : http://bugs.gentoo.org/326209
>>  I have got very similar problem.
> Thanks. This was the point. My Linux Kernel is grsec
>  enabled by default.
> When i load a non grsec Kernel, then ntp works fine on ipv6.

A quick google shows plenty of potentially related results
e.g. <http://bugs.gentoo.org/show_bug.cgi?format=multiple&id=326209>
 .... with grsec NTPd as root IPv6 worked, NTPd as user IPv6 didn't ...
This problem occurs because ntpd does not have the needed
  privileges to access /proc/net/if_inet6 when not run as
  root (USE=caps).
 You can reconfigure to getthe same level of security by
  deselecting CONFIG_GRKERNSEC_PROC_USER and selecting
 You can then add the ntp user to the GID for the special
  group to get it to read the needed info from /proc.

The above aside;
 Have you tried a current NTPd 4.2.7 ?

 In the last three years since the NTP 4.2.4p4
  that you mentioned you were using,
  a lot of things have been worked on,
  IPv6 among them, e.g.

1.2082.4.156 IPv6 addresses in selecting default multicast source addresses.
1.2259       [Bug 1715] sntp utilitiesTest.IPv6Address failed.
1.2082.22.21 [Bug 1080] ntpd on ipv6 routers very chatty.
1.2082.4.97  [Bug 715] libisc Linux IPv6 interface iteration drops multicast flags.
1.2110.1.1   support for IPv6.
1.2082.4.41  Remove ipv6.c as unnecessary
1.2060.10.1  [Bug 1358] AIX 4.3 sntp/networking.c IPV6_JOIN_GROUP undeclared.
1.2060.3.1   [Bug 1343] lib/isc build breaks on systems without IPv6 headers.
1.2058       [Bug 1342] ignore|drop one IPv6 address on an interface blocks all
1.2037       fix ipv4/ipv6 which are not equivalent in the libopts sense
1.2026.1.1   [Bug 1324] support bracketed IPv6 numeric addresses for restrict.
1.2005       Ensure IPv6 localhost address ::1 is included in libisc's Windows IPv6
1.1935       [Bug 1272] gsoc_sntp IPv6 build problems under HP-UX 10.
1.1926       [Bug 1270] CID 70: gsoc_sntp recv_bcst_data mdevadr.ipv6mr_interface
1.1881.2.2   it safe to initialize ipv4_works and ipv6_works before init_io()
1.1881.2.1   3 weeks of changes including IPv6 on Windows which was
1.1873.1.1   some previously separate IPv4/IPv6 paths into a single codepath.
1.1875       [Bug 1200] Enable IPv6 in Windows port
1.1867       [Bug 320] restrict default should apply to both IPv4 and IPv6
1.1735.1.63  IPv6 interfaces were being looked for twice; fix bug 474
1.1735.4.4   [Bug 828] Fix IPv4/IPv6 address parsing
1.1739.1.6   hack ISC_PLATFORM_HAVEIPV6
1.1436.9.5   [Bug 977] Fix mismatching #ifdefs for builds without IPv6
1.1690       [Bug 977] Fix mismatching #ifdefs for builds without IPv6
1.1642       [Bug 828] correct IPv6 address parsing
1.1600       [Bug 771] compare scopeid if available for IPv6 addresses
1.1600       Bug 771: compare scopeid if available for IPv6 addresses
1.1379.1.49  when attempting to send to an IPv6 address of a local interface.

E-Mail Sent to this address <BlackList at Anitech-Systems.com>
  will be added to the BlackLists.

More information about the questions mailing list