[ntp:questions] Problem troubleshooting gps/pps on freebsd 8.1

kbv g8kbv at mail4trash.com
Fri Dec 17 21:43:38 UTC 2010


In article <faa5a6c9-eb67-41f7-b96a-e4760116af91
@c2g2000yqc.googlegroups.com>, pst at telia.com says...
> ntpdc -c kern
> 


Hi.

Looks like you got it all working now, good.   I remember something 
about not to use 9600bd for some reason with earlier NTPD 
implementations, but I think you had evidence that NTPD was "seeing" the 
GPS anyway.

Just looked at my system, and got this...

ntpdc -c kern

pll offset:           9.38e-07 s
pll frequency:        97.403 ppm
maximum error:        0.002487 s
estimated error:      2e-06 s
status:               2107  pll ppsfreq ppstime ppssignal nano
pll time constant:    4
precision:            1e-09 s
frequency tolerance:  496 ppm
pps frequency:        97.403 ppm
pps stability:        0.004 ppm
pps jitter:           3.242e-06 s
calibration interval: 256 s
calibration cycles:   217
jitter exceeded:      42
stability exceeded:   0
calibration errors:   2

and

ntpq -p

remote          refid      st t when poll reach   delay   offset  jitter
========================================================================
*GPS_NMEA(1)    .GPS.       0 l    7   16  377    0.000    0.001   0.002

I'm assuming it's all working OK.   The system that uses it is happy, 
that's the main thing.

That on FreeBSD V8.0, with a Garmin GPS16LVS, indoors!  (Less than 
ideal, but it keeps working till I can get it outside.)

Cheers.

Dave B




More information about the questions mailing list