[ntp:questions] server failover

James, Neil Neil.James at gdcanada.com
Thu Mar 11 20:32:08 UTC 2010


Hi,

 

I have a network of devices that will spend time both with and without a
reliable time source. I have designated one as a server. The ntp.conf
is,

 

pidfile         /var/run/ntpd.pid

driftfile       /var/db/ntp.drift

tos minsane 1 minclock 1

disable auth

tos orphan 10

server 10.0.1.20

manycastserver 224.1.1.1

 

The other devices have an ntp.conf file of,

 

pidfile         /var/run/ntpd.pid

driftfile       /var/db/ntp.drift

tos minsane 1 minclock 1

tos orphan 10

disable auth

manycastclient 224.1.1.1

 

Everything works fine when the external server is present. When I kill
ntp on the external server the device configured as a manycastserver
refuses to  believe that 10.0.1.20 is no longer responding

 

$ ntpq -p

     remote           refid      st t when poll reach   delay   offset
jitter

========================================================================
======

*10.0.1.20       LOCAL(0)         5 u  18h  256    0    0.206   -0.243
0.000

 

Is this normal, what do I need to do to get orphan mode to kick in.

 

Thanks,

Neil

 

Using NTP 4.2.4p7

 


The information contained in this e-mail message is PRIVATE. It may contain confidential information and may be legally privileged. It is intended for the exclusive use of the addressee(s). If you are not the intended recipient, you are hereby notified that any dissemination, distribution or reproduction of this communication is strictly prohibited. If the intended recipient(s) cannot be reached or if a transmission problem has occurred, please notify the sender immediately by return e-mail and destroy all copies of this message. 
Thank you. 




More information about the questions mailing list