[ntp:questions] VM host not snyching time

Steve Kostecke kostecke at ntp.org
Tue Mar 23 23:52:49 UTC 2010


On 2010-03-19, Ramesh <cfmx07 at yahoo.com> wrote:

> I am trying to synchronize the time of my VM server with ntpd. I have
> the following configuration.
>
> And in the /etc/ntp.conf, I have the following line:
>
> restrict default ignore
> restrict 127.0.0.1.
> server time1.server
> server time2.server
>
> Whenever I have this line, the erver is not able to synchronize its
> time... So far as I understood, this line prevents other servers using
> this machine as a time server.

"restrict default ignore" tells ntpd to ignore all NTP packets.

This blocks all access to and from your ntpd.

When you use "restrict default ignore" you must explicitly relax the
restrictions for your remote time servers and your authorized clients.

http://support.ntp.org/Support/AccessRestrictions

http://www.eecis.udel.edu/~mills/ntp/html/accopt.html (ntp-dev
documentation)

http://doc.ntp.org/4.2.6/accopt.html (stable release documentation)

> And the second line says to allow localhost to use as time server.

No, that line does not enable time service.

"restrict 127.0.0.1" relaxes the restrictions for connections from the
localhost (e.g. for status queries).

-- 
Steve Kostecke <kostecke at ntp.org>
NTP Public Services Project - http://support.ntp.org/




More information about the questions mailing list