[ntp:questions] Fwd: Re: NetBSD GPS/PPS using 4.2.6p3

A C agcarver+ntp at acarver.net
Mon Aug 22 19:37:14 UTC 2011

On 8/22/2011 07:45, Miroslav Lichvar wrote:
> On Sun, Aug 21, 2011 at 02:55:55PM -0700, A C wrote:
>> That is where I obtained the ppstest code and then later I
>> discovered the test code within the ntpd source distribution.  The
>> NetBSD list also suggested that I compare kernel traces on the two
>> programs.  It seems that ntpd's pps-api code behaves a bit
>> differently than ntpd itself when it interfaces with the kernel.  I
>> can provide traces to anyone that would like them for both the
>> pps-api test program and ntpd 4.2.6p3.
>>  flag2 0 flag3 1 refid PPS\n\n
>>   11255      1 ntpd     CALL  ioctl(7,PPS_IOC_SETPARAMS,0x1052d204)
>>   11255      1 ntpd     CALL  ioctl(7,PPS_IOC_KCBIND,0xefffdf8c)
> A shot in the dark, have you tried removing "flag3 1" to disable the
> kernel PPS discipline?

Yes but ntpd still doesn't see the PPS signal on DCD with or without 
flag3.  So I'm lost on how to solve this problem.  I know the PPS signal 
is there on the wire, I know DCD is being asserted and cleared.  I know 
the test code can see it but for some reason I just can't make ntpd see it.

More information about the questions mailing list