[ntp:questions] ipv6 multicast not working in ntp-4.2.6p3

Atul Gupta atul14.kumar at gmail.com
Mon Jun 20 19:18:12 UTC 2011


Hi Steve,
I have upgraded my system with new version of ntpd i.e. ntp-4.2.6p3
Now i am getting some different error, ntp is not able to receive the
multicast packets sent by server and continuously throwing message :-
*"select():
nfound=-1, error: Interrupted system call"*
I am ruuning on kernel version
Linux (none) 2.6.28.10.mips-malta #1 PREEMPT Tue Jun 14 16:07:28 EDT 2011
mips unknown



Below is my ntp.conf
multicastclient ff02::101
disable auth
driftfile /var/log/ntp/drift
logfile /var/log/ntp/ntp.log

Please help.

Regards,
Atul.


On Wed, Jun 15, 2011 at 8:44 PM, Steve Kostecke <kostecke at ntp.org> wrote:

> On 2011-06-15, Atul Gupta <atul14.kumar at gmail.com> wrote:
>
> > I am using ntp package ntp-4.2.4.tar.gz
>
> This release is older than you think.
>
> The current stable is ntp-4.2.6p3
>
> ntp-4.2.4   == NTP-4 v2.4
>
> ntp-4.2.6p3 == NTP-4 v2.6.3
>
> > I want to run ntp client
>
> There is no "ntp client". Either you're using ntpd, sntp, or ntpdate.
>
> > in multicast client mode and i added following line
> > in ntp.conf file :-
> >
> > *multicastclient ff05::101*
> >
> > But it seems there is no multicast socket opened on 123.
> > ntp logs show following :-
> >
> > *addto_syslog: getaddrinfo: "ff05::101" invalid host address, ignored
> > getaddrinfo: "ff05::101" invalid host address, ignored.*
>
> Please try using the current stable release. It may be downloaded from
> http://www.ntp.org/downloads.html or http://support.ntp.org/download
>
> Also make sure that your IPv6 networking is configured correctly.
>
> --
> Steve Kostecke <kostecke at ntp.org>
> NTP Public Services Project - http://support.ntp.org/
>
> _______________________________________________
> questions mailing list
> questions at lists.ntp.org
> http://lists.ntp.org/listinfo/questions
>



More information about the questions mailing list