[ntp:questions] ipv6 multicast not working in ntp-4.2.6p3

Atul Gupta atul14.kumar at gmail.com
Mon Jun 20 21:03:34 UTC 2011


Hi Danny,
I am able to receive the multicast packets from ntp server, but in log
client displays something as "ignore" :-
*ignore on (10) fd=17 from fe80::20e:2eff:fe91:9ebc
ignore on (10) fd=17 from fe80::20e:2eff:fe91:9ebc*

where fe80::20e:2eff:fe91:9ebc is the server's address.*

*And, client doesn't start unicast communication with server, and hence
doesn't sync. Is the "ignore" word is also harmless or it has some meaning.
Please take a look at my ntp configuration as well.

*driftfile /var/lib/ntp/drift
log /var/log/apps.log

restrict default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery


restrict 127.0.0.1
restrict -6 ::1

multicastclient ff02::101        # multicast client
disable auth

keys /etc/ntp/keys*

Regards,
Atul.*
*

On Mon, Jun 20, 2011 at 3:51 PM, Danny Mayer <mayer at ntp.org> wrote:

> On 6/20/2011 3:18 PM, Atul Gupta wrote:
> > Hi Steve,
> > I have upgraded my system with new version of ntpd i.e. ntp-4.2.6p3
> > Now i am getting some different error, ntp is not able to receive the
> > multicast packets sent by server and continuously throwing message :-
> > *"select():
> > nfound=-1, error: Interrupted system call"*
> > I am ruuning on kernel version
> > Linux (none) 2.6.28.10.mips-malta #1 PREEMPT Tue Jun 14 16:07:28 EDT 2011
> > mips unknown
> >
>
> That's not an error. You just have debug set too high. If you MUST run
> debug, set it to -D2. In rare instances set it to -D4 if you want to see
> a log of debug. You see this message whenever debug > 5.
>
> Danny
> _______________________________________________
> questions mailing list
> questions at lists.ntp.org
> http://lists.ntp.org/listinfo/questions
>



More information about the questions mailing list