[ntp:questions] ipv6 multicast not working in ntp-4.2.6p3

Danny Mayer mayer at ntp.org
Mon Jun 20 21:32:04 UTC 2011


On 6/20/2011 5:03 PM, Atul Gupta wrote:
> Hi Danny,
> I am able to receive the multicast packets from ntp server, but in log
> client displays something as "ignore" :-
> *ignore on (10) fd=17 from fe80::20e:2eff:fe91:9ebc
> ignore on (10) fd=17 from fe80::20e:2eff:fe91:9ebc*
> 
> where fe80::20e:2eff:fe91:9ebc is the server's address.*
> 
> *And, client doesn't start unicast communication with server, and hence
> doesn't sync. Is the "ignore" word is also harmless or it has some meaning.
> Please take a look at my ntp configuration as well.
> 
> *driftfile /var/lib/ntp/drift
> log /var/log/apps.log
> 
> restrict default kod nomodify notrap nopeer noquery
> restrict -6 default kod nomodify notrap nopeer noquery
> 
> 
> restrict 127.0.0.1
> restrict -6 ::1
> 
> multicastclient ff02::101        # multicast client
> disable auth
> 
> keys /etc/ntp/keys*

Remove all restrict statements first and then test. If it works, read up
on how and why to use restrict statements before you start using them.

Danny



More information about the questions mailing list