[ntp:questions] Problems with NMEA refclocks, Ublox6 GPS, on WinXP with 4.2.7p21 4

Long, Darren Darren.Long at uk.thalesgroup.com
Tue Sep 27 11:03:41 UTC 2011

Hi all,

I tried asking about my problems on the IRC channel #ntp last night but got
no response so I thought I'd try the questions list.

I'm trying to use a pure NMEA refclock (no PPS) on Win XP but I'm not having
any joy. I've been trying with 4.2.7p214 and tested briefly with 4.2.6p4 to
see if it was any better and it didn't seem to be.

I seem to have two problems.  One is specifically related to the particular
GPS device I need to use, and the other seems to be common to the other NMEA
sources I've tried.

I'm specifically trying to get a Ublox6 GPS to talk to ntpd via a USB-UART
at 9600 baud, but the issues with the Ublox6 seem to be more severe than
with the other NMEA sources that I've tried.  With the Ublox6, in
_open_osfhandle(), isdev == FILE_TYPE_UNKNOWN and the function returns -1,
causing nmea_start() to call nmead_open(), which I guess it shouldn't. The
call to nmead_open() also returns -1, causing nmea_shutdown() to be invoked,
so then its game over for that refclock.  If I hack isdev to equal
FILE_TYPE_CHAR, then the results obtained with the Ublox6 are the same as
those described below for other NMEA sources.

I've also tried using a Kenwood D72 transceiver's embedded GPS Rx, also via
its embedded USB-UART, and a GPS Emulator (that's popular with the people at
the diy-drones forum) interfaced with a com0com virtual serial port
connection. With the D72 and the emulator on Windows XP, nmea_start() seems
to succeed, but nmea_receive() never seems to be invoked.

Please note that I've tried both the D72 and the Ublox6 GPS with 4.2.7p214
on Linux and both seem to work fine.

So, I'd appreciate any help with the two issues that I've summarised below:

1) I don't seem to be able to get ntpd to receive NMEA data from any NMEA
source I have available on Win XP, despite having success on Linux (this
also validates my config entries as correct).

2) ntpd can't get a valid file descriptor for the COM port for the Ublox6
Rx's embedded USB-UART on Windows XP, but it works OK on Linux.  Perhaps
this is related to UBlox's Win XP driver, but they seems OK when used with
hyperterm and other apps. Does anyone have any similar or contradictory
experience in this are?



More information about the questions mailing list