[ntp:questions] Problems with NMEA refclocks, Ublox6 GPS, on WinXP with 4.2.7p21 4

Long, Darren Darren.Long at uk.thalesgroup.com
Tue Sep 27 16:38:21 UTC 2011

> -----Original Message-----
> From: Dave Hart [mailto:davehart at gmail.com]

Thanks for the response Dave, I was hoping you'd show up :)

Just a quick reply from me now.

> You can't get a break, can you?  I'm curious what role the GPS
> emulator is playing here.  Why not use the D72 directly?  

I am/have.  I've tried the D72 and the GPS Emulator (with com0com virtual
serial connection) as two independent NMEA sources at different times and
obtained the same results - no invocation of nmea_receive().

> Does putty or another terminal program show you the NMEA transmissions
> second when opening the same COM port as ntpd is attempting?  

Yes, for all 3 sources (Ublox6, D72 and the emu) although the D72 outputs at
1/2Hz rate as expected. The Ublox6 and D72 are running at 9600 baud with a
bunch of useable messages (GGA, GLL, RMC etc) and the emu has been tried at
9600 and 4800 baud with both a bunch of messages and just RMC.  I may also
try the Ublox6 with a com0com/hub4com virtual serial tee upstream of ntpd to
see if this degree of seperation mitigates against the device type confusion
(I expect it will). I'll see what flavour of driver is used under Linux for
the Ublox6 and look for alternative WinXp drivers for it.

I'll be back after I've tried out your other suggestions.


More information about the questions mailing list