[ntp:questions] Problems with NMEA refclocks, Ublox6 GPS, on WinXP with 4.2.7p21 4

Darren Long darren.long at mac.com
Tue Sep 27 17:45:16 UTC 2011

OK, I've hooked the Ublox6 up to a Debian box and I guess I've been wrong when I've described the interface as a USB-UART.  In fact, its using the cdc_acm driver, the "Abstract Control Model driver for USB modems and ISDN adapters", although the device /dev/ttyACM0 is showing up as a character device.  I'm thinking I should have realised something was up when I had to link /dev/gps0 to /dev/ttyACM0 before, as opposed to /dev/ttyUSBx, but no alarm bells rang at the time.

I wonder where that leaves me, w.r.t to using the Ublox6 with ntpd on Win XP.  I suppose I should continue to look at the generic NMEA device issues I'm having for now.



On 27 Sep 2011, at 18:08, Long, Darren wrote:

>> -----Original Message-----
>> From: Dave Hart [mailto:davehart at gmail.com]
>> The GetFileType documentation points out that a return value of
>> FILE_TYPE_UNKNOWN (== 0) means either the function failed, or the type
>> of the handle is unknown, and one must call GetLastError() to know
>> which.  I suggest you debug the problem again and determine what
>> GetLastError() is returning in this path.  My guess is it's returning
>> 0 (no error) indicating the driver handling the USB-connected UART is
>> failing to set the right bits to indicate it's a communications device
>> during the open operation.  
> I can't step into GetLastError() itself, but 0 is being passed into
> _dosmaperr().
>> If GetLastError() is returning an error
>> value, something else is going wrong.  I'd really like to know whether
>> GetFileType() is reporting an error or a legitimate FILE_TYPE_UNKNOWN.
>> Assuming a driver problem, I understand there are relatively few
>> USB-to-UART bridging chips in the market, with something called the
>> pl2003 (IIRC) found in most USB-connected GPS pucks.  With enough
>> spelunking, perhaps you can arrange to use a better Windows driver
>> compatible with your USB-UART hardware to work around this problem.
>> I do question my guess, though, as I'd expect failure to report
>> FILE_TYPE_CHAR would also prevent other terminal apps from using the
>> device, as for example setting the serial port rate and configuration
>> presumably fails on devices that do not present as a communications
>> device.
> Hmm, well, it gets stranger and stranger.  I've just tried connecting to the
> Ublox6 again with putty and some in-house code that is specifically intended
> to work with the USB attached Ublox6, at the wrong baud rate (should be
> 9600, I've tried 19200 and 4800), with wrong number of start and stop bits
> and different parity variations and everything still works, contrary to
> expectations.  I'm now even more confused.  I'll take the Ublox6 home again,
> and hook it up to a Linux box and see what I can learn about the driver it's
> using.
> Cheers,
> Darren
> _______________________________________________
> questions mailing list
> questions at lists.ntp.org
> http://lists.ntp.org/listinfo/questions

More information about the questions mailing list