[ntp:questions] Ignore leap second announcement on NTP

Santi Saez santi at woop.es
Wed Aug 22 13:10:16 UTC 2012

El 21/08/12 15:35, Dave Hart escribió:

> Configuring a leapfile works here, using 4.2.7, to force a local leap
> configuration that ignores upstream leap bits.  I expect the same is
> true of 4.2.6.  I'm afraid I have no information on 4.2.4 or earlier
> leap behavior, as I haven't used 4.2.4 in a number of years.

I've been playing with different ntpd versions and those are the results:

- 4.2.4p4 (Debian Lenny) = not working
- 4.2.4p8 (CentOS-6) = not working
- 4.2.6p2 (Debian Squeeze) = works
- 4.2.6p5 (latest production release) = works
- 4.2.7p295 (latest development release) = works

Seems that versions after 4.2.6, where "leapfile" was introduced in 
order to deploy leap seconds, can overwrite/ignore remote announcement 
setting local configuration, but it doesn't work for previous versions 
(4.2.4 branch) where ntpkey_leap feature is used.

I might use 4.2.6+, but the problem is that I need a scenario where I 
can configure a "master" ntpd and forward this config to the "clients", 
and this doesn't work with version, only works on 4.2.4, see my previous 


In summary: I need a ntpd version where I can ignore leap seconds 
announcements (works with +4.2.6) and forward "leap second" fields to 
the clients (currently *only working* on 4.2.4), thanks!!


Santi Saez

More information about the questions mailing list