[ntp:questions] NTP on Windows Server 2008 R2

David J Taylor david-taylor at blueyonder.co.uk.invalid
Wed Feb 8 17:45:59 UTC 2012

"Geir Guldstein" <dont-spam-geir.guldstein at gmail.com> wrote in message 
news:jfeu9h$6kd$1 at adenine.netfront.net...
>> 1 - You could try setting the /system/ environment variable
>> NTPD_USE_SYSTEM_CLOCK to "1" (or any value)
>> as this will force use of the native clock (to force off 
>> interpolation).
>> However, I'm not sure which version of NTP introduced this feature.
>> 2 - I'm using NTP 4.2.7p241 which has produced excellent results on
>> Windows, so you may also like to try that.
> Thanks David.
> Regarding 1: 4.2.6p5 supports NTPD_USE_SYSTEM_CLOCK. However, I don't 
> think that it will make any difference. I see in the source code 
> (nt_clockstuff.c) that the event log message "using Windows clock 
> directly" (which I get in the case where NTP does *not* work properly) 
> indicates that ntpd already has disabled interpolation. Note that this 
> message is not generated in the case where NTP works reasonably well, 
> which means that it does use interpolation in this case.
> The event log messages indicate that the device driver changes the 
> system clock's resolution:
> Without device driver installed: "Windows clock precision 15.600 msec, 
> min. slew 6.410 ppm/s"
> With device driver installed: "Windows clock precision 0.500 msec, min. 
> slew 6.410 ppm/s"
> In nt_clockstuff.c I see that it is this precision that makes NTP decide 
> to enable or disable interpolation if no environment variables have been 
> set to control it.
> Regarding 2: Thanks, I will try 4.2.7p241.
> Geir


Once you have 4.2.7p241 installed, it's worth trying with and without the 

"Windows clock precision 0.500 msec" concerns me, because it suggests that 
the driver is setting the Windows clock to 2 KHz, whereas the normal range 
is up to 1 KHz maximum.  Not sure how NTP will behave with a clock running 
at twice the expected speed.....


More information about the questions mailing list