Dave Hart davehart_gmail_exchange_tee at davehart.net
Sat Nov 17 03:31:28 UTC 2012

On Wed, Nov 14, 2012 at 10:41 PM,  <gbusenberg at yahoo.com> wrote:
> I tried downloading your binaries for 4.2.7p285.  I stopped the ntp servce, put the new .exe files in my NTP\bin directory and then started the service.  Seems to work however NTPQ may be corrupt. I can open the zip fine.  NTPQ.exe is 735,744 bytes.  When I execute this form the command line, windows opens a crash program box.
> Problem signature:
>   Problem Event Name:   APPCRASH
>   Application Name:     ntpq.exe
>   Application Version:
>   Application Timestamp:        507465f1
>   Fault Module Name:    ntpq.exe
>   Fault Module Version:
>   Fault Module Timestamp:       507465f1
>   Exception Code:       c0000005
>   Exception Offset:     000315a0
>   OS Version:   6.1.7601.
>   Locale ID:    1033
>   Additional Information 1:     0a9e
>   Additional Information 2:     0a9e372d3b4ad19135b953a78882e789
>   Additional Information 3:     0a9e
>   Additional Information 4:     0a9e372d3b4ad19135b953a78882e789

I suspect you have an incompatible version of libeay32.dll in the same
directory as ntpd.exe, left over from the Meinberg installer.  David
Taylor reported to me that the binary Win32 OpenSSL 1.0.0c release
worked with both somewhat older davehart.net ntpd.exe as well as
bleeding-edge ntp-dev 4.2.7 snapshots.  You can install that version
from a copy I placed on my webserver, as the orignal website now
offers only newer 1.x.x releases:


When installing it, I advise against installing their DLLs into the
Windows system32 directory -- it risks breaking other (needlessly
fragile) software that may be using a different OpenSSL version
installed there.  Once it's installed, copy libeay32.dll into the
ntpd.exe directory (such as \Program Files (x86)\ntp\bin).

Dave Hart

More information about the questions mailing list