[ntp:questions] Failure modes on Windows Server 2008 R2 64-bit

Danny Mayer mayer at ntp.org
Tue Aug 13 03:36:16 UTC 2013

On 8/12/2013 6:47 AM, Olo Burrows wrote:
> Has anyone experienced a failure of the Meinberg ntp binaries to run
> on Windows Server 2008 R2?
I don't know what the Meinberg installer does when installing the
binaries though I did provide some advice to them at the time. What you
do need need is to have the Change System Time privilege enabled for the
user account running the service. I believe that local service has that
or you set up an account that specifically includes that privilege. You
have to do that in the Local Security Policy MSC. Either that or have
administrator group. I advise not doing either of these but to establish
a separate account with that privilege and logon as service privilege
and remove it from the Users group.

Also make sure you disable Windows Time.

> I have my suspicions that "something" is odd about this refurbished
> Dell R610 server with brand new installation of 2008 R2 because
> another package was balky when its installation routine came to the
> point of installing it as a service.
> I allowed it to take the many hours required to apply all the Windows
> Updates to bring it current, who knows if one of those munged
> something on which ntp depends.
> Event Viewer was reporting a missing dependency of libeay.dll with
> VC90 (machine is at the shop and on an isolated network, so message
> is from memory). I uninstalled ntp and re-installed it without
> OpenSSL support, then it complained about the missing SSL support.
> Catch-22.
If it was built with VC90 then you need to have the freely available
VC90 runtime installed. You need OpenSSL as the Windows binary is always
built with it.

> Regardless of the SSL issue the only consistent error message is that
> ntp refused to start in a timely manner, which is evidenced by its
> refusal to start period, but I can't pinpoint why. The firewall has
> exceptions, in fact I even disabled the firewall temporarily and that
> didn't change anything. I've given the ntp user ownership and full
> access permissions to that directory tree, no good. I've uninstalled
> and rebooted and tried a number of tweaks, all to no avail. I'm out
> of ideas and time at this point.

Is Windows Time running? If so you need to disable it.


More information about the questions mailing list