[ntp:questions] Silly question.

David Lord snews at lordynet.org
Tue Dec 17 13:39:52 UTC 2013

DaveB wrote:
> In article <slrnlaujq8.ded.kostecke at stasis.kostecke.net>, 
> kostecke at ntp.org says...
>> On 2013-12-16, DaveB <spam.goes at nowhere.com> wrote:
>>> I'm currently stuck, trying to get the system sources, so I can enable 
>>> PPS support in the kernel.   The old "sysinstall" seems broken, in as 
>>> much as it cant seem to download anything from anywhere.
>> http://forums.freebsd.org/viewtopic.php?t=29172 discusses installing
>> FreeBSD 9 source.
> Hi again Steve.
> I'm obviously a total numpty, as either of the methods in that posting 
> fail.  (And yes, I did change 9.0 to 9.2)  I'm guessing FBSD doenst 
> associate ftp: with the ftp protocol when fed it on the command line, 
> unlike some other os's.   (Comes up with command not found.)
> Tried ftp, and got the ftp prompt (ftp>) but even then asking in several 
> ways, all I get is "Not connected".
> If I try to connect first (logical) as I don't know the account details, 
> again, I'm stuffed.
> SVN.  Again, sad to say this is another case where I cant get that to 
> fly either.  I've tried that (and similar for other needs on other OS's 
> in the past) and never got it to work on any platform.   My total lack 
> of understanding of what it is and how to use it.
> Sorry, but I realy need a fully worked and tested blow by blow example 
> to do this sort of simple stuff.   Oddly, I can manage kernel compiles 
> and booting to that just fine, I've done that in the past several times, 
> but I always had the sources from the outset.

have you setup networking?
network interface in /etc/rc.conf
defaultroute in /etc/rc.conf

I've just checked on my not configured freebsd-5.2.1 which needed

ifconfig rl0 netmask
route add default
echo "nameserver" >> /etc/resolv.conf


ftp -4 ftp://ftp.freebsd.org/
connected to ftp.beastie.tdk.net.

In above "rl0"  = my particular interface  = local host ip   = local nameserver and also gateway

"man" is useful so try "man ftp" to get required syntax
"whereis ftp" should give location of ftp command unless your
install is badly broken.

best of luck


> Also, I don't get much contiguious time, so it's poke and hope, fail, go 
> do something else (such as fixing the leaking toilet that's next on the 
> list....)
> Best Regards.
> Confused again.
> Dave B.
> PS:	If the smart money keeps saying "don't use Sysinstall, it's broken 
> and depreciated."  Why the *&%$! is it still present in the system?

More information about the questions mailing list