[ntp:questions] NTP makes a time jump

unruh unruh at invalid.ca
Tue Jul 9 16:36:07 UTC 2013

On 2013-07-09, David Woolley <david at ex.djwhome.demon.invalid> wrote:
> On 09/07/13 09:07, Miroslav Lichvar wrote:
>> I think the kernel would have to be recompiled with a smaller
>> MAXFREQ_SCALED constant or ntpd recompiled with smaller NTP_MAXFREQ if
>> the kernel discipline is disabled.
> The kernel discipline will be disabled if he forces slewing.

That is of course another problem. Maybe he should switch to chrony
which does allow slewing even of large offsets, and does it via kernel
discipline. (Unfortunately it works only on Linux or BSD, so if he is
using windows, that suggestion does not work). Chrony will also allow
slewing faster than 500PPM so that problem does not occur (unless the
slew rate gets up to 100000PPM) 

More information about the questions mailing list