[ntp:questions] pps breaks when nmea is enabled for ntpd

Mike S mikes at flatsurface.com
Sat Jun 15 18:22:33 UTC 2013


On 6/14/2013 9:03 PM, Richard Cagley wrote:
> If I enable an internet server and pps, then pps works great
>
> server clock.redhat.com iburst prefer minpoll 4 maxpoll 4
> server 127.127.22.0 minpoll 4 maxpoll 4
> fudge 127.127.22.0 flag3 1
>
> However, if I add an NMEA server to my ntp.conf file like this
>
> server 127.127.20.0 mode 1
> fudge 127.127.20.0 flag1 1
> server 127.127.22.0 minpoll 4 maxpoll 4
> fudge 127.127.22.0 flag3 1
>
> then pps stops working.

You don't say otherwise, so I assume this is all on the same serial 
port. I think what's happening is that NMEA grabs the serial port first, 
so the separate Atom (PPS) driver doesn't have access.

Don't use the Atom (127.127.22.0) driver, you don't need it. The NMEA 
driver has its own PPS capabilities. You used "flag1 1", which enables 
that support - what did you think that was doing? It doesn't make sense 
to have two different PPS drivers, both driven by the same signal.

This is what I use for a Garmin 18x-LVC.

#       flag1 1 = enable PPS
#       flag2 0 = PPS on assert
#
server  127.127.20.0    mode 1 minpoll 4 maxpoll 4 prefer
fudge   127.127.20.0    time2 0.470 flag1 1 refid gPPS

This works better than using both drivers with different serial ports, 
in my experience.

BTW, you should stop abusing redhat. It's rude to hit a public NTP 
server at maxpoll 4.


More information about the questions mailing list