[ntp:questions] Issues installing ntpd on Win 7

A C agcarver+ntp at acarver.net
Tue Apr 29 04:30:45 UTC 2014


On 2014-04-28 18:37, Brian Inglis wrote:
> On 2014-04-28 17:53, A C wrote:
>> Has anyone recently (within the last few months) tried installing the
>> Meinberg compiled ntpd on Win 7 successfully?  I just built a new
>> machine, put a clean copy of Win 7 on it, tried to install ntpd and
>> ended up with the "unable to start" error (number 1053).  The ntpd user
>> account was created, the service was installed, the directories were
>> populated, the config file was generated but it wouldn't start.
> 
> Which release - current stable 4.2.6p5 - or previous?
> Did you check to see if the process was already running under
> TaskManager all users processes?
> Does the ntp userid have access rights to the config, log, and stats
> directories?
> Are you running on W7 32 or 64 bit?

It's 64 bit Win 7.  The version is the one available on Meinberg's site
(4.2.6p5).  The process was not running when it attempted to start after
installation.  All access controls were fine.

The registry looked the same as below, too.  It just refused to start.
Restarts didn't help either.  All the things one might expect to be
incorrect were fine, it simply refused to start.

> What is the output from the command:
> reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NTP /s
> 
> It should look something like below but perhaps with more quotes and
> backslashes, different paths, and shorter ImagePath (service start
> command line):
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NTP
>     Type    REG_DWORD    0x10
>     Start    REG_DWORD    0x3
>     ErrorControl    REG_DWORD    0x1
>     ImagePath    REG_SZ    "C:\Program Files (x86)\NTP\bin\ntpd.exe" -g
> -M -s C:/ProgramData/NTP/etc/ -p C:/ProgramData/NTP/etc/ntp.pid -l
> C:/ProgramData/NTP/etc/ntp.log -f C:/ProgramData/NTP/etc/ntp.drift -c
> "C:/ProgramData/NTP/etc/ntp.conf"
>     DisplayName    REG_SZ    Network Time Protocol Daemon
>     DependOnService    REG_MULTI_SZ    Tcpip
>     WOW64    REG_DWORD    0x1
>     ObjectName    REG_SZ    .\ntp
>     Description    REG_SZ    Synchronizes the local system clock to a
> reference time source and (eventually) provide this time to NTP and/or
> SNTP clients
> 
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NTP\Parameters
>     ConfigurationFile    REG_SZ    C:/ProgramData/NTP/etc/ntp.conf
> 
> If all else fails, try a restart, then an uninstall, then another
> restart, then another install, then maybe another restart.
> 



More information about the questions mailing list