[ntp:questions] ATOM driver not working on Linux

David Taylor david-taylor at blueyonder.co.uk.invalid
Sun Dec 14 12:32:18 UTC 2014


On 14/12/2014 11:56, Harlan Stenn wrote:
> David Taylor writes:
>> I have a newly installed 64-bit Linux Debian 7.7 system where I am
>> trying to bring up NTP with PPS support.  Using ppstest /dev/pps0 I get
>> the expected assert messages.  I have gpsd configured and working.
>> Having configured and compiled NTP I get the error message:
>>
>>     clock type 22 invalid
>
> That's the parse refclocks.
>
> Did you configure with --enable-parse-clocks ?
>
>> On checking the config.log I see that timepps.h is missing:
>>
>> root at Pixie:~/ntp/ntp-dev-4.2.7p485-RC# cat config.log | grep timepps
>> configure:27520: checking for sys/timepps.h
>> configure:28812: checking timepps.h usability
>> conftest.c:230:21: fatal error: timepps.h: No such file or directory
>> | #include <timepps.h>
>> configure:28812: checking timepps.h presence
>> conftest.c:197:21: fatal error: timepps.h: No such file or directory
>> | #include <timepps.h>
>> configure:28812: checking for timepps.h
>> ac_cv_header_sys_timepps_h=yes
>> ac_cv_header_timepps_h=no
>>
>> but on searching the disk timepps.h does appear to be present, and in
>> the correct directory:
>>
>> root at Pixie:~/ntp/ntp-dev-4.2.7p485-RC# find / -name 'timepps.h'
>> /usr/include/sys/timepps.h
>> /root/ntp/ntp-dev-4.2.7p485-RC/ports/winnt/ppsapi/loopback/src/timepps.h
>> /root/ntp/ntp-dev-4.2.7p485-RC/ports/winnt/include/timepps.h
>>
>> What might be happening, please?  What's wrong?
>
> Some systems provide <timepps.h> and some <sys/timepps.h>.
>
> We look for each.
>
> You have the latter.  My FreeBSD systems also only have sys/timepps.h .
>
> It should be OK that you only have sys/timepps.h .
>
> I suspect your problem is that you built without --enable-parse-clocks .
>
> H
>Thanks for that, Harlan.  I'm at the limit of my knowledge here, so any 
suggestions are appreciated.

I did try the ./configure with --enable-parse-clocks (as well as 
--enable-linuxcaps) but I get the same error in config.log.

It confuses me that on Raspbian (a derivative of Debian) the same source 
builds correctly, using the same commands, and both appear to have 
timepps.h in the same place.
-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list