[ntp:questions] ATOM driver not working on Linux

Harlan Stenn stenn at ntp.org
Sun Dec 14 23:59:54 UTC 2014

David Taylor writes:
> On 14/12/2014 13:23, Harlan Stenn wrote:
> > David Taylor writes:
> []
> >> I did try the ./configure with --enable-parse-clocks (as well as
> >> --enable-linuxcaps) but I get the same error in config.log.
> >
> > You will always get the error that timepps.h doesn't exist because it
> > doesn't exist.  It doesn't need to exist if you have sys/timepps.h .
> >
> >> It confuses me that on Raspbian (a derivative of Debian) the same
> >> source builds correctly, using the same commands, and both appear to
> >> have timepps.h in the same place.
> >
> > Are you cross-compiling?  If so, the headers you build with for
> > cross-compiling are probably not in the same location, and you'll need
> > to install the correct (appropriate) header in the location where the
> > cross-compiler will see it.
> >
> > H
> No, this is a native compile, not cross.
> With sys/timepps.h present I got an ntp which didn't see PPS and 
> produced a "clock type 22 invalid" error message, with  timepps.h 
> present the executable runs PPS correctly.

You mean "with sys/timepps.h present", right?

If clock type 22 is invalid then configure is not being passed the
--enable-parse-clocks option.

You might also need to remove any top-level config.cache* files.


More information about the questions mailing list