[ntp:questions] ATOM driver not working on Linux

Harlan Stenn stenn at ntp.org
Mon Dec 15 09:58:21 UTC 2014


David Taylor writes:
> On 14/12/2014 23:59, Harlan Stenn wrote:
> []
> > You mean "with sys/timepps.h present", right?
> >
> > If clock type 22 is invalid then configure is not being passed the
> > --enable-parse-clocks option.

The above information from me was wrong - type 22 is the ATOM driver,
and it should be automatically detected.

> > You might also need to remove any top-level config.cache* files.
> >
> > H
> 
> Harlan,
> 
> Thanks for your suggestions.  I could not find any config.cache* files, 
> but perhaps I wasn't looking in the right place?
> 
>    find / -name "config.cache*"
> 
> So I deleted everything to do with compiling NTP, and re-ran the tar 
> command to build the source tree.  I removed the /usr/include/timepps.h 
> file, leaving me with just /usr/include/sys/timepps.h, and the configure:
> 
>    ./configure --enable-linuxcaps

You don't need --enable-linuxcaps either - configure will do that for
you automatically if it sees the right files.

> This time, there were no error messages relating to timepps.h, and the 
> compiled ntp runs with PPS support.
> 
> What /may/ have happened is that I did the first compile /before/ 
> installing pps-tools.
> 
> Thanks to you, Brian, Paul and the others who helped.

Glad to hear it's working now.

H


More information about the questions mailing list