[ntp:questions] ATOM driver not working on Linux

David Taylor david-taylor at blueyonder.co.uk.invalid
Tue Dec 16 14:30:02 UTC 2014

On 16/12/2014 14:16, Martin Burnicki wrote:
> Harlan Stenn wrote:
>> David Taylor writes:
>>> I have a newly installed 64-bit Linux Debian 7.7 system where I am
>>> trying to bring up NTP with PPS support.  Using ppstest /dev/pps0 I get
>>> the expected assert messages.  I have gpsd configured and working.
>>> Having configured and compiled NTP I get the error message:
>>>     clock type 22 invalid
>> That's the parse refclocks.
> Nope. The parse clocks are type 8.
>> Did you configure with --enable-parse-clocks ?
> That should not be required to have support for the ATOM driver be
> compiled in.
> On the other hand, I've just been in contact with someone else claiming
> that support for driver 28 was not been compiled in unless
> --enable-parse-clocks was passed to ./configure.
> I couldn't duplicate this, yet, but we should have a closer look at this
> before RC becomes the next release.
> Martin

The good news here is that with the current Raspberry Pi Linux (which as 
PPS built-in), and with pps-tools installed, it seems that I no longer 
need  --enable-linuxcaps  to get PPS support in NTP.

Web: http://www.satsignal.eu

More information about the questions mailing list